bugSavannah Static web pages of project:
savroot

bugbugs #70542: -->CINT segfaults during compilation on Linux ppc64



Submitted by:  Mattias Ellert <mellert>
Submitted on:  2010-07-23 07:43
 
Bug / Feature:  * Bug report Category:  CINT
Priority:  5 - Normal Severity:  3 - Normal
Status:  Wont Fix Privacy:  Public
Assigned to:  Open/Closed:  Closed
Release:  *5.26.00cDiscussion Lock:  Unlocked
Operating System:  * GNU/Linux
Summary:  *CINT segfaults during compilation on Linux ppc64
* Mandatory Fields

2010-08-02 08:49, comment #3:

Hi Chen,

that's not what I see e.g. here https://partner-bugzilla.redhat.com... or here http://mirrors.fedoraproject.org/pu... - from which I read that RHEL6 ppc 32 bit exists and that ppc64 bit allows 32bit binaries.

The problem is CINT's value management: it has an unfortunate ambiguity of int and long. For little endian platforms or 32bit platforms that's fine; big endian 64bit platforms would need a rewrite of all accesses to long values inside CINT. This won't happen because it's too fundamental and we do not plan to put major development efforts in CINT, and because ppc64 is not a "major" platform for us. Sorry.

I will make sure it gets removed form the list of supported platforms; thanks for pointing that out.

Cheers, Axel.

Axel Naumann <axel>In charge of this item.



2010-07-30 15:58, comment #2:

Hi Axel,

RHEL 6 no longer support ppc32, the only available ppc arch for RHEL6 is ppc64.

I can't really understand why the endianness will prevent the building process of cint under ppc64 since ppc32 is also big endianess.

If possible, I think ppc64 support should be added, because it has been listed on the supported architectures of ROOT and more and more ppc machines run 64bit linux.

See http://root.cern.ch/drupal/content/...

Chen Lei <supercyper>



2010-07-23 10:41, comment #1:

Hi,

CINT is not supported on 64bit PPC and I have no plan to port it (the issue being the endianness). You will have to build ROOT as a 32 bit application; it will run just fine on a 64bit OS. Please configure for --arch=linux.

Cheers, Axel.

Axel Naumann <axel>In charge of this item.



2010-07-23 07:43, original submission:

When building root on Linux for ppc64, the compilation ends with a segmentation fault during the invocation of cint_tmp:

cint/cint//main/cint_tmp \
-w1 -zvector -ncint/cint/lib/dll_stl/G__cpp_vector.cxx \
-D__MAKECINT__ -DG__MAKECINT \
-Icint/cint/lib/dll_stl -Icint/cint/lib \
-c-1 -A -Z0 cint/cint/lib/dll_stl/vec.h cint/cint/inc/cintdictversion.h
cint/cint//main/cint_tmp \
-w1 -zvectorbool -ncint/cint/lib/dll_stl/G__cpp_vectorbool.cxx \
-D__MAKECINT__ -DG__MAKECINT \
-Icint/cint/lib/dll_stl -Icint/cint/lib \
-c-1 -A -Z0 cint/cint/lib/dll_stl/vecbool.h cint/cint/inc/cintdictversion.h
make: *** [cint/cint/lib/dll_stl/G__cpp_vectorbool.cxx] Segmentation fault
make: *** Waiting for unfinished jobs....
make: *** [cint/cint/lib/dll_stl/G__cpp_vector.cxx] Segmentation fault
rm core/utils/src/RStl_tmp.cxx core/utils/src/rootcint_tmp.cxx
error: Bad exit status from /var/tmp/rpm-tmp.pzWtSD (%build)

Mattias Ellert <mellert>



 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • Chen Lei <supercyper> added by (supercyper) (Posted a comment)
  • Axel Naumann <axel> added by (axel) (Posted a comment)
  • Rene Brun <brun> added by (brun) (Updated the item)
  • Mattias Ellert <mellert> added by (mellert) (Submitted the item)
  •  

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    2010-07-23 10:41axelStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
      Closed on2010-07-23 10:41=>2010-07-23 10:41
    2010-07-23 10:25brunAssigned toNone=>axel
    Show feedback again

    Back to the top